# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)eps1@(.*)/\1\2/gm;t' <<< "HelpMe_pleas3_eps1@Othertext"