use strict;
my $str = 'HelpMe_pleas3_eps1@Othertext';
my $regex = qr/(.*)eps1@(.*)/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";