#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)IMG[0-9]*.webp"
Local $sString = "<p><img alt=\"\" src=\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG541585829284482.webp\" style=\"width: 320px; height: 82px;\" /></p>\n\n<p><img alt=\"\" src=\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG101585824307864.webp\" style=\"width: 320px; height: 340px;\" /></p>\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")