use strict;
my $str = '<p><img alt=\\"\\" src=\\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG541585829284482.webp\\" style=\\"width: 320px; height: 82px;\\" /></p>\\n\\n<p><img alt=\\"\\" src=\\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG101585824307864.webp\\" style=\\"width: 320px; height: 340px;\\" /></p>\\n';
my $regex = qr/IMG[0-9]*.webp/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}