# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"IMG[0-9]*.webp"
test_str = "<p><img alt=\\\"\\\" src=\\\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG541585829284482.webp\\\" style=\\\"width: 320px; height: 82px;\\\" /></p>\\n\\n<p><img alt=\\\"\\\" src=\\\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG101585824307864.webp\\\" style=\\\"width: 320px; height: 340px;\\\" /></p>\\n"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.