re = /IMG[0-9]*.webp/m
str = '<p><img alt=\\"\\" src=\\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG541585829284482.webp\\" style=\\"width: 320px; height: 82px;\\" /></p>\\n\\n<p><img alt=\\"\\" src=\\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG101585824307864.webp\\" style=\\"width: 320px; height: 340px;\\" /></p>\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end