using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/cms\/api\/preview\/(.*)\/([a-zA-Z]{2}-[a-zA-Z]{2})\/([a-zA-Z0-9-_\/]*)(.*?)(?(4)([a-zA-Z0-9-_=&]*)|)$";
string input = @"/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui
/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui&cap_paperopoli=123
/cms/api/preview/pippo/paperino/en-US/pluto/DePaperoni/paperoga?qui=qua&quo=qui&cap-paperopoli=123
/cms/api/preview/pippo/en-US/pluto23?qua=qui
/cms/api/preview/pippo-clarabella/EN-us/123???
/cms/api/preview/pippo/en-US/pluto-orazio?
/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia
Output for Nginx:
/preview/$1/$3?lang=$2&$5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}