# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\/cms\/api\/preview\/(.*)\/([a-zA-Z]{2}-[a-zA-Z]{2})\/([a-zA-Z0-9-_\/]*)(.*?)(?(4)([a-zA-Z0-9-_=&]*)|)$"
test_str = ("/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui\n"
"/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui&cap_paperopoli=123\n"
"/cms/api/preview/pippo/paperino/en-US/pluto/DePaperoni/paperoga?qui=qua&quo=qui&cap-paperopoli=123\n"
"/cms/api/preview/pippo/en-US/pluto23?qua=qui\n"
"/cms/api/preview/pippo-clarabella/EN-us/123???\n"
"/cms/api/preview/pippo/en-US/pluto-orazio?\n"
"/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia\n\n\n"
"Output for Nginx:\n"
"/preview/$1/$3?lang=$2&$5")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.