import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/cms\\/api\\/preview\\/(.*)\\/([a-zA-Z]{2}-[a-zA-Z]{2})\\/([a-zA-Z0-9-_\\/]*)(.*?)(?(4)([a-zA-Z0-9-_=&]*)|)$";
final String string = "/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui\n"
+ "/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui&cap_paperopoli=123\n"
+ "/cms/api/preview/pippo/paperino/en-US/pluto/DePaperoni/paperoga?qui=qua&quo=qui&cap-paperopoli=123\n"
+ "/cms/api/preview/pippo/en-US/pluto23?qua=qui\n"
+ "/cms/api/preview/pippo-clarabella/EN-us/123???\n"
+ "/cms/api/preview/pippo/en-US/pluto-orazio?\n"
+ "/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia\n\n\n"
+ "Output for Nginx:\n"
+ "/preview/$1/$3?lang=$2&$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}