$re = '/^\/cms\/api\/preview\/(.*)\/([a-zA-Z]{2}-[a-zA-Z]{2})\/([a-zA-Z0-9-_\/]*)(.*?)(?(4)([a-zA-Z0-9-_=&]*)|)$/m';
$str = '/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui
/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui&cap_paperopoli=123
/cms/api/preview/pippo/paperino/en-US/pluto/DePaperoni/paperoga?qui=qua&quo=qui&cap-paperopoli=123
/cms/api/preview/pippo/en-US/pluto23?qua=qui
/cms/api/preview/pippo-clarabella/EN-us/123???
/cms/api/preview/pippo/en-US/pluto-orazio?
/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia
Output for Nginx:
/preview/$1/$3?lang=$2&$5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);