// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/cms\/api\/preview\/(.*)\/([a-zA-Z]{2}-[a-zA-Z]{2})\/([a-zA-Z0-9-_\/]*)(.*?)(?(4)([a-zA-Z0-9-_=&]*)|)$").unwrap();
let string = "/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui
/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui&cap_paperopoli=123
/cms/api/preview/pippo/paperino/en-US/pluto/DePaperoni/paperoga?qui=qua&quo=qui&cap-paperopoli=123
/cms/api/preview/pippo/en-US/pluto23?qua=qui
/cms/api/preview/pippo-clarabella/EN-us/123???
/cms/api/preview/pippo/en-US/pluto-orazio?
/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia
Output for Nginx:
/preview/$1/$3?lang=$2&$5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}