#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^Header 1$(?:\R(?!Header ).*+)*?\RNombre : Juan$(?:\R(?!Header ).*+)*"
Local $sString = "Header 1" & @CRLF & _
"Codigo : c001" & @CRLF & _
"Nombre : Juan" & @CRLF & _
"Total : 45,78" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Header 1" & @CRLF & _
"c001" & @CRLF & _
"Nombre : Juan" & @CRLF & _
"Cantidad : 23" & @CRLF & _
"Subtotal : 45.89" & @CRLF & _
"" & @CRLF & _
"Total : 3410.67" & @CRLF & _
"" & @CRLF & _
"Header 1" & @CRLF & _
"Codigo : c002" & @CRLF & _
"Nombre : Ana" & @CRLF & _
"Total : 45.89 " & @CRLF & _
"Header 1" & @CRLF & _
"c001" & @CRLF & _
"Nombre : Juan" & @CRLF & _
"Cantidad:4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")