const regex = /^Header 1$(?:\R(?!Header ).*+)*?\RNombre : Juan$(?:\R(?!Header ).*+)*/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Header 1$(?:\\R(?!Header ).*+)*?\\RNombre : Juan$(?:\\R(?!Header ).*+)*', 'mig')
const str = `Header 1
Codigo : c001
Nombre : Juan
Total : 45,78
Header 1
c001
Nombre : Juan
Cantidad : 23
Subtotal : 45.89
Total : 3410.67
Header 1
Codigo : c002
Nombre : Ana
Total : 45.89
Header 1
c001
Nombre : Juan
Cantidad:4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}