using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Header 1$(?:\R(?!Header ).*+)*?\RNombre : Juan$(?:\R(?!Header ).*+)*";
string input = @"Header 1
Codigo : c001
Nombre : Juan
Total : 45,78
Header 1
c001
Nombre : Juan
Cantidad : 23
Subtotal : 45.89
Total : 3410.67
Header 1
Codigo : c002
Nombre : Ana
Total : 45.89
Header 1
c001
Nombre : Juan
Cantidad:4";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}