re = /^Header 1$(?:\R(?!Header ).*+)*?\RNombre : Juan$(?:\R(?!Header ).*+)*/mi
str = 'Header 1
Codigo : c001
Nombre : Juan
Total : 45,78
Header 1
c001
Nombre : Juan
Cantidad : 23
Subtotal : 45.89
Total : 3410.67
Header 1
Codigo : c002
Nombre : Ana
Total : 45.89
Header 1
c001
Nombre : Juan
Cantidad:4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end