# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Header 1$(?:\R(?!Header ).*+)*?\RNombre : Juan$(?:\R(?!Header ).*+)*"
test_str = ("Header 1\n"
"Codigo : c001\n"
"Nombre : Juan\n"
"Total : 45,78\n\n\n\n"
"Header 1\n"
"c001\n"
"Nombre : Juan\n"
"Cantidad : 23\n"
"Subtotal : 45.89\n\n"
"Total : 3410.67\n\n"
"Header 1\n"
"Codigo : c002\n"
"Nombre : Ana\n"
"Total : 45.89 \n"
"Header 1\n"
"c001\n"
"Nombre : Juan\n"
"Cantidad:4")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.