import Foundation
let pattern = #"^Header 1$(?:\R(?!Header ).*+)*?\RNombre : Juan$(?:\R(?!Header ).*+)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Header 1
Codigo : c001
Nombre : Juan
Total : 45,78
Header 1
c001
Nombre : Juan
Cantidad : 23
Subtotal : 45.89
Total : 3410.67
Header 1
Codigo : c002
Nombre : Ana
Total : 45.89
Header 1
c001
Nombre : Juan
Cantidad:4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)