#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:(?:- ?)?\d*\.?\d+|(?:var|perg|ind)?\((?1)\))(?:[-+*\/](?1))*)$"
Local $sString = "9-8+" & @CRLF & _
"(ind(10)+15)-10" & @CRLF & _
"(ind(10)+15-10" & @CRLF & _
"1000-(perg(25)*2)" & @CRLF & _
"1000-perg(25)*2)" & @CRLF & _
"1000-perg(25)*2" & @CRLF & _
"25/var(1)" & @CRLF & _
"12*2-(58+1)/5" & @CRLF & _
"(perg(6)*perg(4)*)*1000000" & @CRLF & _
"0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")