$re = '/^((?:(?:- ?)?\d*\.?\d+|(?:var|perg|ind)?\((?1)\))(?:[-+*\/](?1))*)$/m';
$str = '9-8+
(ind(10)+15)-10
(ind(10)+15-10
1000-(perg(25)*2)
1000-perg(25)*2)
1000-perg(25)*2
25/var(1)
12*2-(58+1)/5
(perg(6)*perg(4)*)*1000000
0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);