use strict;
my $str = '9-8+
(ind(10)+15)-10
(ind(10)+15-10
1000-(perg(25)*2)
1000-perg(25)*2)
1000-perg(25)*2
25/var(1)
12*2-(58+1)/5
(perg(6)*perg(4)*)*1000000
0';
my $regex = qr/^((?:(?:- ?)?\d*\.?\d+|(?:var|perg|ind)?\((?1)\))(?:[-+*\/](?1))*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}