import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:(?:- ?)?\\d*\\.?\\d+|(?:var|perg|ind)?\\((?1)\\))(?:[-+*\\/](?1))*)$";
final String string = "9-8+\n"
+ "(ind(10)+15)-10\n"
+ "(ind(10)+15-10\n"
+ "1000-(perg(25)*2)\n"
+ "1000-perg(25)*2)\n"
+ "1000-perg(25)*2\n"
+ "25/var(1)\n"
+ "12*2-(58+1)/5\n"
+ "(perg(6)*perg(4)*)*1000000\n"
+ "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}