// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:(?:- ?)?\d*\.?\d+|(?:var|perg|ind)?\((?1)\))(?:[-+*\/](?1))*)$").unwrap();
let string = "9-8+
(ind(10)+15)-10
(ind(10)+15-10
1000-(perg(25)*2)
1000-perg(25)*2)
1000-perg(25)*2
25/var(1)
12*2-(58+1)/5
(perg(6)*perg(4)*)*1000000
0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}