using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:(?:- ?)?\d*\.?\d+|(?:var|perg|ind)?\((?1)\))(?:[-+*\/](?1))*)$";
string input = @"9-8+
(ind(10)+15)-10
(ind(10)+15-10
1000-(perg(25)*2)
1000-perg(25)*2)
1000-perg(25)*2
25/var(1)
12*2-(58+1)/5
(perg(6)*perg(4)*)*1000000
0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}