# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\.(.*)/$1/gm;t' <<< "https://bbc.com
https://bbc.co.uk
https://bbc.js
https://bbc.edu.test.uk"