use strict;
my $str = 'https://bbc.com
https://bbc.co.uk
https://bbc.js
https://bbc.edu.test.uk';
my $regex = qr/.*\.(.*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";