#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*\.(.*)"
Local $sString = "https://bbc.com" & @CRLF & _
"" & @CRLF & _
"https://bbc.co.uk" & @CRLF & _
"" & @CRLF & _
"https://bbc.js" & @CRLF & _
"" & @CRLF & _
"https://bbc.edu.test.uk"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)