#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!\.)(?!.*\.$)(?!.*?\.\.)([a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+)@((?!\.)(?!.*\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$"
Local $sString = "pete@openanswers.co.uk" & @CRLF & _
"pete.Davies@openanswers.co.uk" & @CRLF & _
"pete.Da!#$%&'*+vies@openanswers.co.uk" & @CRLF & _
"pete.Davies@open-answers.co.uk" & @CRLF & _
"pete.Davies.@openanswers.co.uk" & @CRLF & _
"pete.Davies@.openanswers.co.uk" & @CRLF & _
"pete.Davies@openanswers.co.uk-" & @CRLF & _
"pete.Davies@openanswers.co.uk." & @CRLF & _
"pete.Davies@openanswers.co..uk" & @CRLF & _
"pete..Davies@openanswers.co.uk" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)