using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\.)(?!.*\.$)(?!.*?\.\.)([a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+)@((?!\.)(?!.*\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$";
string substitution = @"";
string input = @"pete@openanswers.co.uk
pete.Davies@openanswers.co.uk
pete.Da!#$%&'*+vies@openanswers.co.uk
pete.Davies@open-answers.co.uk
pete.Davies.@openanswers.co.uk
pete.Davies@.openanswers.co.uk
pete.Davies@openanswers.co.uk-
pete.Davies@openanswers.co.uk.
pete.Davies@openanswers.co..uk
pete..Davies@openanswers.co.uk
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}