import Foundation
let pattern = ##"^(?!\.)(?!.*\.$)(?!.*?\.\.)([a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+)@((?!\.)(?!.*\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
pete@openanswers.co.uk
pete.Davies@openanswers.co.uk
pete.Da!#$%&'*+vies@openanswers.co.uk
pete.Davies@open-answers.co.uk
pete.Davies.@openanswers.co.uk
pete.Davies@.openanswers.co.uk
pete.Davies@openanswers.co.uk-
pete.Davies@openanswers.co.uk.
pete.Davies@openanswers.co..uk
pete..Davies@openanswers.co.uk
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)