use strict;
my $str = 'pete@openanswers.co.uk
pete.Davies@openanswers.co.uk
pete.Da!#$%&\'*+vies@openanswers.co.uk
pete.Davies@open-answers.co.uk
pete.Davies.@openanswers.co.uk
pete.Davies@.openanswers.co.uk
pete.Davies@openanswers.co.uk-
pete.Davies@openanswers.co.uk.
pete.Davies@openanswers.co..uk
pete..Davies@openanswers.co.uk
';
my $regex = qr/^(?!\.)(?!.*\.$)(?!.*?\.\.)([a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+)@((?!\.)(?!.*\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";