const regex = /^(?!\.)(?!.*\.$)(?!.*?\.\.)([a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+)@((?!\.)(?!.*\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\.)(?!.*\\.$)(?!.*?\\.\\.)([a-zA-Z0-9.!#$%&\'*+\\\/=?^_`{|}~-]+)@((?!\\.)(?!.*\\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$', 'gm')
const str = `pete@openanswers.co.uk
pete.Davies@openanswers.co.uk
pete.Da!#\$%&'*+vies@openanswers.co.uk
pete.Davies@open-answers.co.uk
pete.Davies.@openanswers.co.uk
pete.Davies@.openanswers.co.uk
pete.Davies@openanswers.co.uk-
pete.Davies@openanswers.co.uk.
pete.Davies@openanswers.co..uk
pete..Davies@openanswers.co.uk
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);