#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=[^@]*[a-z])(?![^@\r\n]*(?:\+\.|\.\+))[a-z\d+_.-]+@[a-z\d-]+\.[a-z\d-]*[a-z]$"
Local $sString = "a1+-_.@2b-.c3-d" & @CRLF & _
"_1+-_.@2b-.c3-d" & @CRLF & _
"a1$-._@2b-.c3-d" & @CRLF & _
"a1+.-2@2b-.c3-d" & @CRLF & _
"a1.+_.@2b-.c3-d" & @CRLF & _
"a1+-_.@2$-.c3-d" & @CRLF & _
"a1+-_.@2.b.c3-d" & @CRLF & _
"a1+-_.@2b-.$3-d" & @CRLF & _
"a1+-_.@2b-.c3-4" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")