import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^@]*[a-z])(?![^@\\r\\n]*(?:\\+\\.|\\.\\+))[a-z\\d+_.-]+@[a-z\\d-]+\\.[a-z\\d-]*[a-z]$";
final String string = "a1+-_.@2b-.c3-d\n"
+ "_1+-_.@2b-.c3-d\n"
+ "a1$-._@2b-.c3-d\n"
+ "a1+.-2@2b-.c3-d\n"
+ "a1.+_.@2b-.c3-d\n"
+ "a1+-_.@2$-.c3-d\n"
+ "a1+-_.@2.b.c3-d\n"
+ "a1+-_.@2b-.$3-d\n"
+ "a1+-_.@2b-.c3-4\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}