const regex = /^(?=[^@]*[a-z])(?![^@\r\n]*(?:\+\.|\.\+))[a-z\d+_.-]+@[a-z\d-]+\.[a-z\d-]*[a-z]$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^@]*[a-z])(?![^@\\r\\n]*(?:\\+\\.|\\.\\+))[a-z\\d+_.-]+@[a-z\\d-]+\\.[a-z\\d-]*[a-z]$', 'gmi')
const str = `a1+-_.@2b-.c3-d
_1+-_.@2b-.c3-d
a1\$-._@2b-.c3-d
a1+.-2@2b-.c3-d
a1.+_.@2b-.c3-d
a1+-_.@2\$-.c3-d
a1+-_.@2.b.c3-d
a1+-_.@2b-.\$3-d
a1+-_.@2b-.c3-4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}