$re = '/^(?=[^@]*[a-z])(?![^@\r\n]*(?:\+\.|\.\+))[a-z\d+_.-]+@[a-z\d-]+\.[a-z\d-]*[a-z]$/mi';
$str = 'a1+-_.@2b-.c3-d
_1+-_.@2b-.c3-d
a1$-._@2b-.c3-d
a1+.-2@2b-.c3-d
a1.+_.@2b-.c3-d
a1+-_.@2$-.c3-d
a1+-_.@2.b.c3-d
a1+-_.@2b-.$3-d
a1+-_.@2b-.c3-4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);