using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^@]*[a-z])(?![^@\r\n]*(?:\+\.|\.\+))[a-z\d+_.-]+@[a-z\d-]+\.[a-z\d-]*[a-z]$";
string input = @"a1+-_.@2b-.c3-d
_1+-_.@2b-.c3-d
a1$-._@2b-.c3-d
a1+.-2@2b-.c3-d
a1.+_.@2b-.c3-d
a1+-_.@2$-.c3-d
a1+-_.@2.b.c3-d
a1+-_.@2b-.$3-d
a1+-_.@2b-.c3-4
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}