use strict;
my $str = 'a1+-_.@2b-.c3-d
_1+-_.@2b-.c3-d
a1$-._@2b-.c3-d
a1+.-2@2b-.c3-d
a1.+_.@2b-.c3-d
a1+-_.@2$-.c3-d
a1+-_.@2.b.c3-d
a1+-_.@2b-.$3-d
a1+-_.@2b-.c3-4
';
my $regex = qr/^(?=[^@]*[a-z])(?![^@\r\n]*(?:\+\.|\.\+))[a-z\d+_.-]+@[a-z\d-]+\.[a-z\d-]*[a-z]$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}