package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/([ac])\/(\d{1,4})\/(\d{1,4})\/([a-zA-Z\d\._-]+)\/(.*)`)
var str = []byte(`/a/94/403/webolizer/1461075495.84270.webmail5581.mynet.com%3A1228350129winmail.dat`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}