import re
regex = re.compile(r"""
^\/([ac])\/(\d{1,4})\/(\d{1,4})\/([a-zA-Z\d\._-]+)\/(.*)
""", flags=re.VERBOSE)
test_str = "/a/94/403/webolizer/1461075495.84270.webmail5581.mynet.com%3A1228350129winmail.dat"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)