#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)\{.*?\}"
Local $sString = "Leave only {" & @CRLF & _
" remove everything" & @CRLF & _
" in here" & @CRLF & _
"} this text"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)