re = /(?s)\{.*?\}/m
str = 'Leave only {
remove everything
in here
} this text'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result