package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)\{.*?\}`)
var str = `Leave only {
remove everything
in here
} this text`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}