use strict;
my $str = 'Leave only {
remove everything
in here
} this text';
my $regex = qr/(?s)\{.*?\}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";