import re
regex = re.compile(r"(?s)\{.*?\}", flags=re.MULTILINE)
test_str = ("Leave only {\n"
" remove everything\n"
" in here\n"
"} this text")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)