$re = '/(?s)\{.*?\}/m';
$str = 'Leave only {
remove everything
in here
} this text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;