#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9a-zA-z]{10}\(\\x01[0-9]{1}\\x02([0-9]{2})\\x02[0-9]{2}\\n"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4nY6zVk61Z(\x010\x0205\x0202\n" & @CRLF & _
"4nY8GkxuEy(\x010\x0201\x0202\n" & @CRLF & _
"4nYA5W4GtJ(\x010\x0205\x0202\n" & @CRLF & _
"4nY6zVk61Z(\x010\x0205\x0202\n" & @CRLF & _
"" & @CRLF & _
"4nY8spkhEULA1701\x0276\x0276\x011(\x012(\n" & @CRLF & _
"4nY8spkhEULA1701\x0276\x0276\x011(\x012(\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"\x02([0-9]{2})\x02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")