import Foundation
let pattern = #"^[0-9a-zA-z]{10}\(\\x01[0-9]{1}\\x02([0-9]{2})\\x02[0-9]{2}\\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
4nY6zVk61Z(\x010\x0205\x0202\n
4nY8GkxuEy(\x010\x0201\x0202\n
4nYA5W4GtJ(\x010\x0205\x0202\n
4nY6zVk61Z(\x010\x0205\x0202\n
4nY8spkhEULA1701\x0276\x0276\x011(\x012(\n
4nY8spkhEULA1701\x0276\x0276\x011(\x012(\n
\x02([0-9]{2})\x02
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)