import re
regex = re.compile(r"^[0-9a-zA-z]{10}\(\\x01[0-9]{1}\\x02([0-9]{2})\\x02[0-9]{2}\\n", flags=re.MULTILINE)
test_str = ("\n\n\n\n\n"
"4nY6zVk61Z(\\x010\\x0205\\x0202\\n\n"
"4nY8GkxuEy(\\x010\\x0201\\x0202\\n\n"
"4nYA5W4GtJ(\\x010\\x0205\\x0202\\n\n"
"4nY6zVk61Z(\\x010\\x0205\\x0202\\n\n\n"
"4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n\n"
"4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n\n\n\n\n\n"
"\\x02([0-9]{2})\\x02")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")