using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\+\(?[0-9]{1,3}|\(?\b[0-9]{4})\)?)?\h*\)?[-\h.]?\(?[0-9]{1,3}\)?[-\h.]?[0-9]{3}[-\h.]?[0-9]{3,4}";
string input = @"+1555555555
+4974339296
+591 74339296
+1 555 555 5554
+(591) 7433433
+(591) (4) 6434850
0591 74339296
0001 5555555555
(0001) 5555555
59145678464
3298494333";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}