package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:\+\(?[0-9]{1,3}|\(?\b[0-9]{4})\)?)?\h*\)?[-\h.]?\(?[0-9]{1,3}\)?[-\h.]?[0-9]{3}[-\h.]?[0-9]{3,4}`)
var str = `+1555555555
+4974339296
+591 74339296
+1 555 555 5554
+(591) 7433433
+(591) (4) 6434850
0591 74339296
0001 5555555555
(0001) 5555555
59145678464
3298494333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}